View all Products Close Menu Menu
Security Update for Legacy Services in 2021
Updated Thursday July 8th 2021 / Category Web Hosting

In the first half of 2021, we will be updating security protocols across our legacy fleet to ensure all of our services are compliant with the latest Payment Card Industry Data Security Standards (PCI DSS).

By performing this change we are ensuring that we maintain a safe and secure environment for your hosting service.

Our quick 3 step check that you’re connecting with a compatible system

1. Your Operating System

If you are using one of the following operating systems, you will need to update your operating system to be able to connect using the updated security protocols

  • Windows XP and older Windows operating systems
  • Pre Mac OSX 10.11
  • Pre Android 4.4.4
  • Pre iOS 5

The best thing to do would be to update your Operating System to the latest version possible. This will ensure that your computer can use modern encryption and connect securely.

If you are still using Windows 7, you can click here to find out what actions you will need to take.

2. Email apps compatible with TLS versions 1.2 and above

If you use email through your hosting service, click the links below for further instructions on ensuring you’re connected securely on the following email apps:

3. FTP apps compatible with TLS versions 1.2 and above

If you use FTP to transfer files to and from your shared hosting service, click the links below for further instructions on ensuring you’re connected securely on the following file transfer (FTP) apps:

Why can’t VentraIP Australia support SSL or earlier versions of TLS?

VentraIP Australia implements PCI DSS security standards, which requires us to disable support for older versions of SSL and TLS. The reason behind this is the older versions are very old and insecure now, and cannot be used for the transmission of private or confidential information.

Our intentions are entirely positive here, we want to provide the best quality and most secure services possible. This includes finding the best balance between security and compatibility that we can.

The versions that we no longer support are SSL 1, SSL 2, SSL 3,  TLS 1.0 and TLS 1.1. These versions are 20+ years old and have been replaced by some more modern encryption protocols and standards.

Rest assured, most modern computers, devices and operating systems already support the newer versions of the TLS encryption protocols (versions 1.2 and 1.3). It’s only older operating systems and software that don’t support the new encryption.

Can’t find the answers you're looking for? Check out these other methods of support!