24/7 Australian Sales & SupportCall 13 24 85
View all Products Close Menu Menu
Why you need to update your computer to connect to VentraIP Australia's new servers
Updated Wednesday October 21st 2020 / Category Web Hosting

At VentraIP Australia, we want to make our platform as safe and secure as possible and that means implementing various security standards and practices that help us do that. This means that we cannot support some older encryption protocols such as SSL 1.0, SSL 2.0, SSL 3.0, TLS 1.0, TLS 1.1. As they are now considered insecure.

Unfortunately, some operating systems such as Windows XP, Windows Vista, Windows 7 and any version of Mac OSX prior to 10.9 either do not support more modern encryption or still support and may use older encryption methods. Sometimes this can cause the user to experience issues connecting to our platform.

A key thing to keep in mind here, is the encryption standards and protocols we no longer support are now 20+ years old. And have been known to be insecure for almost as long.

 

Can’t find the answers you're looking for? Check out these other methods of support!