24/7 Australian Sales & SupportCall 13 24 85
View all Products Close Menu Menu
SSL/TLS settings on our new servers and why they're important
Updated Wednesday October 21st 2020 / Category Web Hosting

In an effort to ensure our services meet PCI DSS Compliance standards, we have to disable some of the older versions of SSL and TLS. At the moment, all legacy hosting services support older encryption protocols, however our new servers do not.

The reason they need to be disabled is because they’re now insecure and cannot be safely used to encrypt data. And most of the versions of SSL/TLS that are being disabled are 20+ years old now and are only used by fairly old Operating Systems and devices, such as Windows XP.

Can’t find the answers you're looking for? Check out these other methods of support!