pattern
month long deals
vw hero
vw hero
more details
View all Products Close Menu Menu
Troubleshooting SSL and TLS compatibility issues
Updated Tuesday May 11th 2021 / Category Web Hosting

Check that you’re connecting with a compatible system

Email apps compatible with TLS versions 1.2 and above

Click the links below for further instructions on ensuring you’re connected securely on the following email apps:

FTP apps compatible with TLS versions 1.2 and above

Click the links below for further instructions on ensuring you’re connected securely on the following file transfer (FTP) apps:

Operating systems compatible with TLS versions 1.2 and above

Here is a table that shows which Microsoft Windows and Mac OSX operating system support TLS 1.2.

Operating System

TLS 1.2

Windows XP

NO

Windows XP – Service Pack 3

NO

Windows Vista

NO

Windows 7

YES *

Windows 8

YES

Windows 10

YES

Pre Mac OSX 10.9

NO

Mac OSX 10.9+

YES

Android 1.0 to 4.4.4

NO

Android 4.4.4+

YES

Android 5+

YES

* Please note, if you are using Windows 7, you may need to configure Windows to use TLS 1.2. You can find out more information here.

What should I do if I am using an operating system that doesn’t support TLS 1.2 or above?

The best thing to do would be to update your Operating System to the latest version possible. This will ensure that your computer can use modern encryption and connect securely.

Why has TLS become the standard over SSL?

SSL 2.0 (Secure Socket Layer) was originally released in 1995 and was soon replaced by SSL 3.0 in 1996. The protocols are quite old now, and over the years security flaws have been found in the protocols. Which meant that it was insecure and needed to be replaced.

There was  SSL 1.0 before 1995, however, it was never released because TLS 1.0 was released in 1999, and was intended to be a replacement for SSL. Because TLS 1.o was largely based on the now insecure SSL 3 protocol, and TLS 1.1 is now insecure and vulnerable to attack as well. The most notable was the POODLE attack. There are now newer versions of TLS (1.2 and 1.3) which are more secure and considered safe to use.

Why can’t VentraIP Australia support SSL or earlier versions of TLS?

VentraIP Australia implements PCI DSS security standards, which requires us to disable support for older versions of SSL and TLS. The reason behind this is the older versions are very old and insecure now, and cannot be used for the transmission of private or confidential information.

Our intentions are entirely positive here, we want to provide the best quality and most secure services possible. This includes finding the best balance between security and compatibility that we can.

The versions that we no longer support are SSL 1, SSL 2, SSL 3,  TLS 1.0 and TLS 1.1. These versions are 20+ years old and have been replaced by some more modern encryption protocols and standards.

Rest assured, most modern computers, devices and operating systems already support the newer versions of the TLS encryption protocols (versions 1.2 and 1.3). It’s only older operating systems and software that don’t support the new encryption.

Can’t find the answers you're looking for? Check out these other methods of support!